import re
regex = re.compile(r"([房间])*[收拾|清洁|打扫|清理|整理|换枕头|换床单].{0,3}([房间|卫生|一下])*[垃圾]*", flags=re.MULTILINE)
test_str = ("嗯,你有男朋友吗?\n"
"你是机器人吧?\n"
"嗯,你好,那个帮我打扫下房间好吗?现在。\n"
"五分钟后帮我打扫下,卫生。\n"
"你是人工台吗?\n"
"唉,那个你们这那个服务员现在马上帮我整理房间的,我下去吃饭了,一会我还上来。\n"
"清理房间,现在。\n"
"现在可以清理房间。\n"
"你有男朋友吗?\n"
"嗯,请现在帮我打扫一下房间。\n"
"嗯,现在马上需要房间打扫。\n"
"这个是人工服务吗?\n"
"嗯,送两瓶水,然后三点以后打扫房间。\n"
"现在打扫卫生。\n"
"把这个我的房间上它现在来给我清理一下,一会来客人。\n"
"打扫房间?\n"
"打扫卫生。\n"
"帮我打扫下房间。\n"
"嗯,打扫房间。\n"
"帮我打扫一下房间。\n"
"嗯,打扫卫生。\n"
"嗯,帮我打扫下房间。\n"
"清理房间?\n"
"房间打扫?\n"
"打扫?\n"
"帮我打扫房间。\n"
"打扫一下房间。\n"
"房间打扫一下。\n"
"打扫下房间?\n"
"请帮我打扫下房间。\n"
"收拾房间?\n"
"明天早上六点叫我起床。\n"
"嗯,打扫下,卫生。\n"
"整理房间?\n"
"叫服务员帮整理房间。\n"
"您好,打扫卫生。\n"
"五零二打扫房间?\n"
"换床单。\n"
"房间需要打扫。\n"
"呃,打扫房间。\n"
"收垃圾。\n"
"嗯,房间打扫。\n"
"房间打扫卫生。\n"
"打扫房间卫生?\n"
"换一下床单。\n"
"打扫服务。\n"
"请打扫房间?\n"
"五点的叫醒服务,帮忙给我改一下改成五点半的。\n"
"喂,你好,你打扫一下,我房间。\n"
"那个房间漏水了,请尽快派人来修理打扫吧。\n"
"嗯,拿两瓶水,今天还没打扫房间,卫生。\n"
"嗯,打扫房间吧。\n"
"叫来打扫房间?\n"
"哎,明天早上七点四十莫林。\n"
"你这服务员帮我房间打扫下。\n"
"哦,叫个来打扫。\n"
"你好,请帮我找人打扫房间?\n"
"嗯,帮我收的水过来。\n"
"请帮我打扫一下房间。\n"
"要七五六帮我去打扫一下。\n"
"帮我预约明天早上七点的叫醒。\n"
"我打扫房间,然后把那个洗淑用品的换一下。\n"
"明天七点的叫醒我。\n"
"嗯,六六六房间,我想加紧打扫卫生。\n"
"给那个服务部打电话打扫卫生。\n"
"清楚,有房间打扫一下为止。\n"
"下午帮我打扫下房间就九五二。\n"
"哎,你好,就是我们是那个九五六那个帮忙打扫一下。\n"
"嗯,收拾下房间。\n"
"麻烦请收拾一下房间里的垃圾。\n"
"嗯,你好,可以换一下被子吗?\n"
"人来收拾下房间,谢谢。\n"
"那个没有人来帮我收拾一下房间吗?\n"
"嗯,四点钟叫醒。\n"
"房间卫生打扫一下。\n"
"这房间打扫一下。\n"
"嗯,收一下房间。\n"
"哎,我刚才已经交了来啦,一干洗的衣服怎么的,现在没人来,来洗衣服洗衣服。\n"
"嗯,我需要全面打扫房间。\n"
"西郊那个呃,这帮我们收一下那个垃圾。\n"
"请问来打扫卫生。\n"
"您好,明天五点五十叫醒服务。\n"
"哎,你好,我哎你好,我想找人打扫房间?\n"
"喂,你好,能不能就是把那个九零幺房间打扫一下。\n"
"能不能打扫房间了?\n"
"哎,你好,那个九幺八房间帮我们来打扫一下行吗?\n"
"下午给九零幺房间打扫一下。\n"
"嗯,明天早上帮您看八点半。\n"
"可不可以清理房间。\n"
"房间帮我打扫一下,今天不退房。\n"
"明天早上五点叫我一下吧。\n"
"您好,收拾垃圾。\n"
"嗯,送两瓶水,然后三点以后打扫房间。\n"
"垃圾清理。\n"
"清理房间,现在。\n"
"打扫卫生,打扫房间?\n"
"啊,你好,这个房间已经延迟一天麻烦你派个人过来打扫卫生。\n"
"嗯,明天早上七点半叫醒一下。\n"
"嗯,我要打扫房间。\n"
"叫服务员过来打扫一下房间。\n"
"嗯,那个等一下请过来打扫一下卫生。\n"
"你好,能帮我先过来打扫一下房间吗?\n"
"嗯,你好,那个房间麻烦安排过来打扫下。\n"
"帮我订一个二十七号下午三点的叫醒。\n"
"嗯,你好,我这边叫的打扫卫生,怎么还没来。\n"
"清洁打扫房间?\n"
"嗯,明天五点叫醒啊。\n"
"麻烦帮我打扫一下。\n"
"可以打扫房间了,谢谢。\n"
"嗯,这个打扫卫生。\n"
"请帮我安排一下打扫房间卫生。\n"
"呃,交人过来把房间打扫一下。\n"
"帮打扫房间打扫房间?\n"
"嗯,你好,那个帮我打扫下房间好吗?现在。\n"
"嗯,能帮我安排一下,打扫卫生吗?还有一个是什么来着?\n"
"设置明天早上六点五十的叫醒服务。\n"
"我打扫下,卫生。\n"
"这个房间清理一下。\n"
"早上九点叫醒。\n"
"你好,那个先可以打扫滴幺八幺二吗,让我住下。\n"
"嗯,帮我打扫房间。\n"
"嗯,打扫房间,谢谢。\n"
"我这里卫生还没打扫我们住的是那个,那个那个那个房间。\n"
"嗯,再个人来整理房间?\n"
"帮我打扫下房间幺二幺六。\n"
"明天早上五点叫醒一下。\n"
"安排打扫。\n"
"帮我转到给我找一个清洁清洁的阿姨的可以吗?\n"
"嗯,请帮忙打扫一下吧,五六房间,谢谢。\n"
"您好,那个打扫卫生。\n"
"嗯,你好,我想要一个明天早上六点钟的叫醒服务。\n"
"嗯,我需要房间打扫一下。\n"
"那二打扫房间。\n"
"哦,麻烦七零八打扫一下房间。\n"
"请打扫吧,幺二房间。\n"
"嗯,不是要要打扫要房间吗?\n"
"帮我安排下打扫房间?\n"
"哎呀,我们这个房间没有帮我们清理房间收拾房间吗?那个浴巾那个床被什么都没有换吗。\n"
"一点十五叫我起床。\n"
"您好,那个呃,请打扫下房间。\n"
"我,我要零六八房间需要打扫。\n"
"嗯,打扫。\n"
"你们哪六点叫醒吗?谢谢啊。\n"
"现在打扫卫生。\n"
"哎,你好,能找人帮我打扫下房间吗?\n"
"七点十五分叫醒确定吗,确定吗?\n"
"喂,你好,能找前台那个幺五零二这个房间门上了他处理快餐。\n"
"你好,我这里是五一二房间那个早上还没有打扫麻烦您叫人过来帮我们打扫一下,谢谢。\n"
"帮我房间收拾下。\n"
"我想打扫一下,我房间。\n"
"你好,请安排打扫下,卫生。\n"
"收拾?\n"
"唉,你能不能提供那个吸尘器服务。\n"
"哦,我那个房间打扫一下。\n"
"未听给我打扫下房间吗?\n"
"您这早上五点三十分叫醒。\n"
"嗯,能帮我安排下,打扫卫生吗?\n"
"啊,我们那个房间需要打扫。\n"
"啊,打扫卫生。\n"
"我需要打扫一下房间。\n"
"我的房间需要清理。\n"
"我打扫房间?\n"
"请问可以帮我打扫一下房间吗?\n"
"哎,你好,那个我这二五零九这屋子需要用吸尘器把那个会成一下好吗?\n"
"嗯,打扫下零九。\n"
"把这个我的房间上它现在来给我清理一下,一会来客人。\n"
"您好,让服务员过来打扫房间?\n"
"七十机器人来给我打扫下房间。\n"
"个房间有话筒吧,用那个三点钟在打扫吧。\n"
"七幺七,明天早上八点叫醒。\n"
"八点半叫醒。\n"
"不一样,我要打扫一下房间洗衣服。\n"
"那个八六零,我这里是明天早上六点二十叫醒服务。\n"
"嗯,你好,我那个房间的能不能找人帮我打扫一下。\n"
"嗯,请帮嗯请帮我打扫一下未房间卫生。\n"
"嗯,那个打扫卫生。\n"
"有一个今天下午三点的叫醒。\n"
"今天不用打扫房间了。\n"
"嗯,卫生打扫。\n"
"帮我打扫下,卫生吗?\n"
"呃我房间需要清理。\n"
"订个五点的叫醒服务。\n"
"请叫人给我打扫一下房间。\n"
"嗯,明天早晨六点五十分叫醒。\n"
"我二零三打扫房间都说那个怎么还没安排啊。\n"
"清理下反证卫生。\n"
"声打扫卫生。\n"
"嗯,请帮我打扫一下,幺二幺要房间。\n"
"嗯,我要房间要打扫。\n"
"帮我把房间打扫一下。\n"
"唉,你好,呃,你今天那个呃打扫卫生的时候有没有帮我那个床单过来。\n"
"啊,请把房间打扫一下。\n"
"嗯,你能帮我安排下,打扫卫生吗?\n"
"为什么没有人打扫卫生。\n"
"嗯,帮我打扫一下卫生。\n"
"啊打扫为什么?\n"
"打扫卫生早餐?\n"
"嗯,让服务员过来整理一下房间。\n"
"五分钟后帮我打扫下,卫生。\n"
"我们房间要帮我打扫打理一下。\n"
"安排人给我房间打扫下。\n"
"哦,想叫个过来打扫下房间?\n"
"哎,你好,我这个七五八房间,麻烦来打扫一下卫生。\n"
"嗯,叫服务员打扫房间。\n"
"哎,你好,幺七零八打扫一下房间。\n"
"嗯,请现在帮我打扫一下房间。\n"
"嗯,需要打扫房间。\n"
"啊,我怎么我帮我打扫房间。\n"
"叫他打扫卫生。\n"
"明天上午七点叫起叫醒。\n"
"啊,喂,你好,能帮我那个明天早上七点半叫醒我吧。\n"
"嗯,帮我叫一下保洁过来打扫一下吧。\n"
"你好,叫服务员把我房间整理一下。\n"
"亲,明天早上五点叫醒。\n"
"嗯,打扫下房间。\n"
"唉,请打扫下卫生。\n"
"要七六零打扫。\n"
"明天早上五点半叫醒我。\n"
"唉,那个你们这那个服务员现在马上帮我整理房间的,我下去吃饭了,一会我还上来。\n"
"啊,要来打扫卫生。\n"
"麻烦打扫卫生赠送水果。\n"
"打扫房间的怎么还没过来。\n"
"嗯,我打扫卫生。\n"
"你好,帮我打扫房间。\n"
"嗯,我要打扫一下卫生。\n"
"六点半叫醒。\n"
"喂,你好,请帮我来打扫一下房间好吗?\n"
"为什么今天没有打扫卫生啊。\n"
"明天上午七点三十分叫早六一九号房。\n"
"嗯,请打扫卫生。\n"
"请立即请帮我打扫下房间。\n"
"嗯,我想明天早上六点半叫早。\n"
"你好,给我打扫下房间。\n"
"那是九零要打扫卫生。\n"
"哎,你好,要五二幺这边卫生嘉里没只了那个送点纸吗?\n"
"嗯嗯,下午六点钟叫我一下。\n"
"给我打扫房间,马上。\n"
"你好,请帮我房间打扫下。\n"
"嗯,让服务员给我来打扫一下房间卫生。\n"
"准备帮我打扫房间呢?\n"
"您好,烦请有垃圾请清理。\n"
"你好,麻烦过来帮我整理一下房间吧,把传单被套的换一下。\n"
"没打扫卫生。\n"
"你好,八零九吧,收拾房间呗。\n"
"请抓紧给我打扫房间。\n"
"五点半叫醒。\n"
"把房间打扫一下。\n"
"喂,你好,请帮我打扫房间。\n"
"喂,你好,是能不能来就是把九零幺打扫一下。\n"
"喂,你好,请你给我打扫一下六七零房间。\n"
"喂,你好,我想厅打扫下房间。\n"
"你好来打扫一下房间。\n"
"服务员帮我房间打扫一下。\n"
"可以帮忙收一下门口的垃圾吗?\n"
"九六八打扫房间。\n"
"请帮我来打扫一下微信可以吧。\n"
"啊,帮我安排下,打扫卫生。\n"
"帮我定明天早上三点的叫醒。\n"
"嗯,帮我订一个八点和八点五十的叫醒。\n"
"呃,这个房间帮我打扫一下好吗?\n"
"嗯,四点半叫醒好。\n"
"嗯,给我打扫房间。\n"
"好人打扫房间?\n"
"客房清洁。\n"
"我半年打扫一下。\n"
"请房间打扫一下。\n"
"那个过来我房间打扫下。\n"
"那个麻烦能帮我打扫下房间吗?房房间间没有打扫。\n"
"嗯,让服务员打扫一下,要六零三房间。\n"
"七七零打扫房间?\n"
"收一下房间。\n"
"嗯,房间卫生改一下的。\n"
"我这个帮清理下房间吗?\n"
"嗯,保险打扫一下,然后推荐去。\n"
"嗯,可麻烦服务员来打扫卫生吗?\n"
"嗯,明天那个五点十五分叫醒。\n"
"六点十八分叫醒我号码。\n"
"八点的叫醒。\n"
"我需要清洁服务。\n"
"但是我打扫房间调承担。\n"
"嗯,马上我打扫下,卫生。\n"
"幺六零九打扫房间?\n"
"六点半叫我起床。\n"
"麻烦把房间打扫一下。\n"
"嗯,下午五点的叫醒。\n"
"帮我打扫卫生,房间卫生。\n"
"我安排个人收拾下房间呗。\n"
"六六六房间需要清理房间。\n"
"你能过来帮我收一下垃圾吗?\n"
"可以帮我打扫一下房间卫生吗?\n"
"换枕头。\n"
"清洁。\n"
"把房间清理一下呢。\n"
"去马上帮我打扫吧。\n"
"那个给我弄个七点十分的叫醒吧。\n"
"你好,将来那个整理房间。\n"
"您好,请到我房间来收一下果盘。\n"
"嗯,请立刻打扫卫生。\n"
"你好,请麻烦你叫服务员来给清理下房间,好吧。\n"
"您好,这服务员帮整理房间。\n"
"请帮我打扫房间。\n"
"我想打扫一下房间。\n"
"明天早上七点半叫醒。\n"
"我过来打扫下房间。\n"
"嗯,我们打算了一个玻璃板能不能帮我清理下。\n"
"九零三卫生来打扫一下。\n"
"嗯,你帮我收拾房间。\n"
"布拖。\n"
"喂,你好,下午帮我打扫下房间。\n"
"哎,你好,给我们把房间打扫一下。\n"
"嗯,能帮我打扫下房间吗?\n"
"嗯,你能帮我安排一下,打扫卫生吗?\n"
"嗯,给清理下房间。\n"
"嗯,麻烦帮我房间打扫一下,要八五八吗?\n"
"叫服务员那个打扫卫生啊,拜拜,嗯。\n"
"唉,你好,嗯,幺六六零九号房需要打扫一下。\n"
"请麻烦你来帮我打扫一下房间吗?\n"
"查收一下只是免费的吗?是固定的吗?\n"
"嗯,请帮我叫上来打扫一下房间今天没有打扫房间。\n"
"那个帮我打扫下房间。\n"
"嗯,明天五点半叫醒我。\n"
"嗯,请打扫一下房间吧。\n"
"请帮我房间卫生打扫下。\n"
"啊,你好,我想我是那个二幺零二房客,我想了解一下,嗯,那个像是多长时间打扫卫生啊,我看我已经将近四五天了,一直没有打扫卫生,我想了解一下。\n"
"麻烦帮我八零一打扫一下卫生。\n"
"嗯,帮忙清理房间。\n"
"嗯,你好,麻烦明天早上八点叫醒一下。\n"
"明天早上六点四十叫醒。\n"
"打扫下卫生。\n"
"你好,幺五幺幺幺五幺幺打扫卫生。\n"
"麻烦你来打扫卫生。\n"
"嗯,房间清理一下。\n"
"现在想赶快要洗衣服,那收一下吧,因为我明天退房,明天中午也要。\n"
"速度过来,打扫卫生。\n"
"帮打扫下房间。\n"
"嗯,叫他们帮我打扫下房间幺幺零幺。\n"
"嗯,九零三帮我们打扫一下房间。\n"
"八点叫醒。\n"
"您好,请问来清洁房间。\n"
"嗯,早上六点叫我起床。\n"
"请帮忙打扫。\n"
"请马上打扫打扫房间?\n"
"帮我们打扫一下房间。\n"
"为方便的时候把那个床单换一下吗?\n"
"你好,明天给我叫醒三点叫醒好吧。\n"
"这部要打扫房间?\n"
"七七零打扫下房间。\n"
"那个帮我打扫房间。\n"
"嗯,房间收视一下。\n"
"我都,我现在洗衣服的话最快什么时候能给我送回来。\n"
"现在可以清理房间。\n"
"我,我们收拾下吧。\n"
"通知打扫房间?\n"
"嗯,打扫一下,反正卫生。\n"
"嗯,现在马上需要房间打扫。\n"
"帮我整理房间。\n"
"九二零打扫一下房间。\n"
"你好,服务员整理房间。\n"
"嗯,帮我订一个八点五十的叫早。\n"
"六点五十分叫醒。\n"
"哎,你好,我要一个明天早上六点的叫早服务。\n"
"啊,早上七点三十叫醒。\n"
"烧打扫房间?\n"
"嗯,嗯,您好,帮我看一零房间打扫一下。\n"
"房打扫卫生?\n"
"他们打扫房间?\n"
"五分钟后,我要洗下衣服。\n"
"请吧,要七五六的房间打扫一下。\n"
"啊,我给我们这个打扫卫生了咋还没来了。\n"
"打扫下,要六五二房间。\n"
"请打扫卫生吧,上。\n"
"嗯,打扫下房间呢?\n"
"为啥洗衣服务,现在马上过来。\n"
"你好,打扫卫生。\n"
"哎,帮忙叫一下那个打扫房间。\n"
"嗯,请帮我把房间打扫一下。\n"
"九六八收一下垃圾。\n"
"那个我这里今天没打扫卫生,但是。\n"
"九五二打扫房间?\n"
"麻烦给打扫下房间吗?\n"
"你这打扫房间?\n"
"行,换一下床单。")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")