re = /(start.*)?(start.*end)/m
str = 'Situated start about 150 start miles start(240 km) north of Las Vegas, the remote start hamlet of just 50 year-round start residents lacks a grocery store end or even a gasoline station.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end