# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?si)m_dwErrorCode\s*=\s*(?<code>\dx\d+);\s*_stprintf\(.*?\(.*?\((?<description>.*?)\).*?;\s*m_dwOutError\s*=\s*(?<error>[\w_]+);\s*m_OutSeverity\s*=\s*(?<severity>[\w_]+)"
test_str = ("m_dwErrorCode = 0; \n"
"m_dwOutError = HOP_OK; \n"
"m_OutSeverity = CCC_INFORMATION; \n"
"_stprintf(m_OutDevStr, _T(\"\"));\n"
"if (0x00000000 & value)\n"
"{\n"
" \n"
" m_dwErrorCode = 0x0;\n"
" /* Ready state. */\n"
" // m_StatusStr = \" Ready(eSTATUS_READY)\";\n"
"}\n"
"if (0x00000001 & value)\n"
"{\n"
" m_bProceeding = true;\n"
" /* proceed */\n"
" //m_StatusStr = \" Proceeding(eSTATUS)\";\n"
"}\n"
"if (0x00002000 & value)\n"
"{\n"
" m_bEmpty = true;\n"
" // We only want to check this error only at certain times.\n"
" if (m_bCheckEmpty)\n"
" {\n"
" if ((m_Attributes.dwMediaID == CUBE1) ||\n"
" (m_Attributes.dwMediaID == CUBE2) ||\n"
" /*(m_Attributes.dwMediaID == SCALLOPED) ||*/ // Added\n"
" (m_Attributes.dwMediaID == FOLDED))\n"
" {\n\n"
" m_dwErrorCode = 0x00002000;\n"
" _stprintf(m_OutDevStr, _T(\"0x1000 - %s(MP Tray Empty)\"), errorStr);\n"
" m_dwOutError = HOP_TRAY_EMPTY;\n"
" m_OutSeverity = CCC_INFORMATION;\n"
" }\n"
" }\n"
" //HOP_TRAY_EMPTY\n"
" ///* MSI empty. */\n"
" //m_bTrayEmpty = true;\n"
" //// m_StatusStr = \" MSI empty(eSTATUS_MSI_EMPTY)\";\n"
"}\n"
"if (0x00004000 & value)\n"
"{\n"
" /* empty. */\n"
" m_dwErrorCode = 0x4000;\n"
" _stprintf(m_OutDevStr, _T(\"0x4000 - %s(Tray 1 empty)\"), errorStr);\n"
" m_dwOutError = HOP_TRAY_01_EMPTY;\n"
" m_OutSeverity = CCC_INFORMATION;\n"
"}\n"
"if (0x00008000 & value)\n"
"{\n"
" /* Tray 2 empty. */\n"
" m_dwErrorCode = 0x8000;\n"
" _stprintf(m_OutDevStr, _T(\"0x8000 - %s(Tray 2 empty)\"), errorStr);\n"
" m_dwOutError = HOP_TRAY_02_EMPTY;\n"
" m_OutSeverity = CCC_INFORMATION;\n"
"}\n"
"if (0x00010000 & value)\n"
"{\n"
" /* Tray 3 empty. */\n"
" m_dwErrorCode = 0x10000;\n"
" _stprintf(m_OutDevStr, _T(\"0x10000 - %s(Tray 3 empty)\"), errorStr);\n"
" m_dwOutError = HOP_TRAY_03_EMPTY;\n"
" m_OutSeverity = CCC_INFORMATION;\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.