re = /^(?i)((?=\bApproved\b).)*((?!\bMr\b).)*$/m
str = 'Abc your request is Approved .
Mr. Abc your request is Approved.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end