$re = '/\b\d{1,2}/\d{1,2}(?!/)\b/m';
$str = '15/1/2014
1/5
1/5-
1/5a
15/1//201';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);