using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<url>(https?:.//?|www\.).*?)(?:</ref>|[,]|[\]]|[ ]|[ ]|[<])";
string input = @"<ref>Melon busk + shorten domain https://www.youtube.com/watch?v=2j3p_aDMTNg</ref> => Valid
<ref>vidéo privé https://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub</ref> => Invalid - privé
<ref>rick roll [https://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_playe http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_playe]</ref> => Valid
<ref>ajout source redirect home page - https://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player</ref> => Valid
<ref>rick roll avec share https://youtube.com/shorts/dQw4w9WgXcQ?feature=share'</ref> => Valid
<ref>Video indisponible (pas TOS, pas privé) - https://www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0%2C</ref> => Invalid
<ref>lien de chaine https://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo</ref> => Valid - lien de chaine
<ref>chaine indisponnible [https://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I]</ref> => Invalid
<ref>video indisponnible https://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub</ref> => Invalid
<ref>Embedded video https://www.youtube.com/embed/nas1rJpm7wY?rel=0</ref> => Valid
<ref> Multiple url reference [https://www.youtube.com/watch?v=ubNF9QNEQLA, https://www.youtube.com/watch?v=ubNF9QNEQLA]</ref> => Semi-valid - Multiple reference
<ref> nowiki referefence <nowiki>https://www.youtube.com/watch?v=ubNF9QNEQLA</nowiki></ref> => Semivalid - nowiki tag
<ref>playlist avec plusieurs videos https://www.youtube.com/playlist?list=PLUTbk4P4tNYQ99rLpgq9eKAjZpiQh7Ay4</ref> => valid - playlist
<ref>https://www.youtube.com/playlist?list=PLUTbk4P4tNYQ99rLpgq9eKAjZpiQh7Ay4</ref> => valid sans metadata
<ref>https://www.youtube.com/playlist?list=PLUTbk4P4tNYQ99rLpgq9eKAjZpiQh7Ay4 - https://www.youtube.com/playlist?list=PLUTbk4P4tNYQ99rLpgq9eKAjZpiQh7Ay4</ref> => multiple links
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}