#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^\$translateProvider\.translations\('de', {)[\s\S]*(?=}\)$)"
Local $sString = "$translateProvider.translations('de', {" & @CRLF & _
" WASTE_MANAGEMENT: 'Abfallmanagement'," & @CRLF & _
" WASTE_TYPE_LIST: 'Abfallarten'," & @CRLF & _
" WASTE_ENTRY_LIST: 'Abfalleinträge'," & @CRLF & _
" WASTE_TYPE: 'Abfallart'," & @CRLF & _
" TREATMENT_TYPE: 'Behandlungsart'," & @CRLF & _
" TREATMENT_TYPE_STATUS: 'Status Behandlungsart'," & @CRLF & _
" DUPLICATED_TREATMENT_TYPE: 'Doppelte Behandlungsart'," & @CRLF & _
" TREATMENT_TYPE_LIST: 'Behandlungsarten'," & @CRLF & _
" TREATMENT_TARGET_LIST: 'Ziele Behandlungsarten'," & @CRLF & _
" TREATMENT_TARGET_ADD: 'Ziel Behandlungsart hinzufügen'," & @CRLF & _
" SITE_TARGET: 'Gebäudeziel'," & @CRLF & _
" WASTE_TREATMENT_TYPES: 'Abfallbehandlungsarten'," & @CRLF & _
" WASTE_TREATMENT_TARGETS: '{{Abfallbehandlungsziele}}'," & @CRLF & _
" WASTE_TREATMENT_TYPES_LIST: '{{Abfallbehandlungsarten}}'," & @CRLF & _
" WASTE_TYPE_ADD: 'Abfallart hinzufügen'," & @CRLF & _
" UNIT_ADD: 'Einheit hinzufügen'" & @CRLF & _
"})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")