re = /^(?!.*\?)(.*?)\&(.*?)$/
str = 'http://localohst/test/&lang=it&iframe=1&iframe=1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end