import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$")
test_str = ("Blablabla\n"
"Bj4\n"
"Vj4kl4kzgf9G\n"
"VjklkzgfG\n"
"VjklkzgfG_\n"
"Blablabla4\n"
"blablabla4\n"
"bdasDSADAsd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")