$re = '/(?<![ ]{2})\b\d{5}\b(?![ ]{2})/m';
$str = '12345
12345
12345
12345
hello 12345 world
12345
12345
hello 12345 world
aaa12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);