#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<code1>id="question-summary-)(?<code2>\d+)"
Local $sString = "<div class="question-summary" id="question-summary-80407">" & @CRLF & _
" <div class="statscontainer">" & @CRLF & _
" <div class="statsarrow"></div>" & @CRLF & _
" <div class="stats">" & @CRLF & _
" <div class="vote">" & @CRLF & _
" <div class="votes">" & @CRLF & _
" <span class="vote-count-post "><strong>2</strong></span>" & @CRLF & _
" <div class="viewcount">votes</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="status answered">" & @CRLF & _
" <strong>1</strong>answer" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="views " title="60 views">" & @CRLF & _
" 60 views" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="summary">" & @CRLF & _
" <h3><a href="/questions/80407/about-power-supply-of-opertional-amplifier" class="question-hyperlink">about power supply of opertional amplifier</a></h3>" & @CRLF & _
" <div class="excerpt">" & @CRLF & _
" I am constructing an operational amplifier as shown in the following figure. I use a batter as supplier for the OP Amp and set it up as a non-inverting amp circuit. I saw that the output was clipped ..." & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="tags t-op-amp">" & @CRLF & _
" <a href="/questions/tagged/op-amp" class="post-tag" title="show questions tagged 'op-amp'" rel="tag">op-amp</a>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" <div class="started fr">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="user-info ">" & @CRLF & _
" <div class="user-action-time">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" asked <span title="2013-08-27 21:49:14Z" class="relativetime">11 hours ago</span>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="user-gravatar32">" & @CRLF & _
" <a href="/users/17060/user1285419"><div class=""><img src="https://www.gravatar.com/avatar/08ee68b20a4eceff26f7eee99b708c08?s=32&d=identicon&r=PG" alt="" width="32" height="32"></div></a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="user-details">" & @CRLF & _
" <a href="/users/17060/user1285419">user1285419</a><br>" & @CRLF & _
" <span class="reputation-score" title="reputation score" dir="ltr">165</span><span title="5 bronze badges"><span class="badge3"></span><span class="badgecount">5</span></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="question-summary" id="question-summary-80405">" & @CRLF & _
" <div class="statscontainer">" & @CRLF & _
" <div class="statsarrow"></div>" & @CRLF & _
" <div class="stats">" & @CRLF & _
" <div class="vote">" & @CRLF & _
" <div class="votes">" & @CRLF & _
" <span class="vote-count-post "><strong>4</strong></span>" & @CRLF & _
" <div class="viewcount">votes</div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="status answered-accepted">" & @CRLF & _
" <strong>2</strong>answers" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="views " title="64 views">" & @CRLF & _
" 64 views" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="summary">" & @CRLF & _
" <h3><a href="/questions/80405/5v-regulator-power-dissipation" class="question-hyperlink">5V Regulator Power Dissipation</a></h3>" & @CRLF & _
" <div class="excerpt">" & @CRLF & _
" I am using a 5V regulator (LP2950) from ON Semiconductor. I am using this for USB power and I'm feeding in 9V from an adapter. USB requires maximum of 500mA right? So the maximum power dissipation in ..." & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="tags t-voltage-regulator t-surface-mount t-heatsink t-5v t-power-dissipation">" & @CRLF & _
" <a href="/questions/tagged/voltage-regulator" class="post-tag" title="show questions tagged 'voltage-regulator'" rel="tag">voltage-regulator</a> <a href="/questions/tagged/surface-mount" class="post-tag" title="show questions tagged 'surface-mount'" rel="tag">surface-mount</a> <a href="/questions/tagged/heatsink" class="post-tag" title="show questions tagged 'heatsink'" rel="tag">heatsink</a> <a href="/questions/tagged/5v" class="post-tag" title="show questions tagged '5v'" rel="tag">5v</a> <a href="/questions/tagged/power-dissipation" class="post-tag" title="show questions tagged 'power-dissipation'" rel="tag">power-dissipation</a>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" <div class="started fr">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="user-info ">" & @CRLF & _
" <div class="user-action-time">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" asked <span title="2013-08-27 21:39:31Z" class="relativetime">11 hours ago</span>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="user-gravatar32">" & @CRLF & _
" <a href="/users/10082/david-norman"><div class=""><img src="https://www.gravatar.com/avatar/8b073417e471077280b3fc5ff2eaf1f7?s=32&d=identicon&r=PG" alt="" width="32" height="32"></div></a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="user-details">" & @CRLF & _
" <a href="/users/10082/david-norman">David Norman</a><br>" & @CRLF & _
" <span class="reputation-score" title="reputation score" dir="ltr">322</span><span title="3 silver badges"><span class="badge2"></span><span class="badgecount">3</span></span><span title="10 bronze badges"><span class="badge3"></span><span class="badgecount">10</span></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")