re = /(?:\G(?!\A)|{)[^{}]*?\K\([^()]*\)/m
str = '{foo (i,j) bar} should match on (i,j)
{(i,j) foo (k,l) bar (m,n,o)} should match on (i,j), (k,l), and (m,n,o).
foo (i,j) bar should not match on anything because the string is not between swirly brackets.
{foo (i,j) bar} (k,l) should match on (i,j) but not (k,l) because the latter is outside of the swirly brackets.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end