import re
regex = re.compile(r"<[^>]*>", flags=re.MULTILINE)
test_str = "[</w:t></w:r><w:r w:rsidR=\"00042557\"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR=\"00042557\" w:rsidRPr=\"004C3B57\"><w:t>]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)