re = /^(?!\d{4}-\d{10})(?!\d{10}-\d{4})\d{4}-?\d{6}-?\d{4}$/m
str = '1111-111111-1111
12341234561234
1111-111111111
1111111111-1111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end