$re = '/\b\d+\b(?!%)/';
$str = 'You should attemp 100% in every test and score 100.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);