$re = '/^(0|-?[1-9][0-9]{0,5})$/';
$str = '-125345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);