$re = '/\{([^{}]+)\}/x';
$str = 'abc_pqrs_xyx_zdd does { 0} abc_pqrs_xyx_zdd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);