const regex = /([wW]-([0-9]{1,3})[kK][gG])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([wW]-([0-9]{1,3})[kK][gG])', 'g')
const str = `w-23Kg W-23KG W-23kg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}