import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+) (?:<(CARRE)> (\\d+) (\\d+) (\\d+) (\\d+) </CARRE>|<(RECTANGLE)> (\\d+) (\\d+) (\\d+) (\\d+) </RECTANGLE>|<(CERCLE)> (\\d+) (\\d+) (\\d+) </CERCLE>|<(OVALE)> (\\d+) (\\d+) (\\d+) (\\d+) </OVALE>|<(LIGNE)> (\\d+) (\\d+) (\\d+) (\\d+) </LIGNE>)$";
final String string = "1111 <CARRE> 123 321 111 222 </CARRE>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}