re = /^(?=.*[0-9])(?=.*[!@#$%^&*])(?=.*[a-z])(?=.*[A-Z])[a-zA-Z0-9!@#$%^&*]{10,16}$/
str = 'asdf@A1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end