re = /^([a-zA-Z0-9]+)(@)([a-zA-Z0-9]+(\.[a-zA-Z0-9]+)(\.[a-zA-Z0-9]+))*$/
str = 'mrk447@gmail.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end