re = /\b[A-Z0-9]{2}\b|(?<=[A-Z]{3})\d+\.\d{2}[A-Z0-9]{2}(?= .*END)/m
str = 'ABC WS PIT342.55USD342.55END
ABC WS YMQ234.03WS TOY234.03USD468.06END
FUR BB LAB Q10.00 199.00USD209.00END
YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END
PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END
YAS DL X/XXX MO X/POP DF PSC241.30ET X/SAE DL X/KOO DL CSG269.80USD511.10END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end