package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?7([0-9]{10})$`)
var str = `+79001234567
+7900123456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}