const regex = /(\S| )+\n(\S| )+\n(\S| )+\n((\S| )+|)NSW \d{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S| )+\\n(\\S| )+\\n(\\S| )+\\n((\\S| )+|)NSW \\d{4}', 'g')
const str = `/////// 4 lines & 3rd line is suburb only
SCIENTIFIC MOTOR BODYWORKS LP
7-9 PERRY STREET
MATRAVILLE
NSW 2036
///////
au
Mascot Auto Repairs"cod**
155 Coward Street
Mascot NSW 2020
////////////////////////
Mascot Airport Service Station *cod*
Inside Car Wash
237 O'Riordan St
Mascot NSW 2020
////////////////////////maps
7/30-32 Beaconsfield Street
Alexandria NSW 2015
////////////////////////
Pedders Mascot
Unit 1
20 Ricketty Street
Mascot NSW 2020
/////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12/122 Station Rd
Seven Hills NSW 2147
////////////////////
Pay Charge
Mr Bump Smash Repair
Unit 12 122 Station Rd
Seven Hills NSW 2147
/////// suburb spelling error, character in street line
Woollahra Auto***cod***
120, Oxford St
Woolahra NSW 1350
/// name not complete
North Caringbah Smash Rep
47 Captain Cook Drive
Caringbah NSW 2229
/////
BM Pro Service Centre
Unit8/ 1a Pritchard Plac
Peakhurst  NSW 2210 
////
embassy smash repairs
unit 5d 23-25 windsor rd
northmead nsw 2152`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}