$re = '/(Name = [A-Z])([A-Z]+)-/m';
$str = 'Name = CASTFORM-1';
$subst = "\1\L\2-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;