$re = '/^.{4}(#+\s+.*)/s';
$str = 'abc
## My Title
xyz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);