$re = '/(.*),(.*),(.*),(.*)/';
$str = 'string1,string2,string3,string4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);