package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([^\s\X])`)
var str = ` GEO X GEO3 X GEO4 X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}