$re = '/((\w+)\s(\w+)\s(\w+))/';
$str = 'one two three one two three one two three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);