use strict;
my $str = '+----------------+---------------+------------+
| Reference Date | Instrument ID | Entity ID |
+----------------+---------------+------------+
| 2019-06-28 4251675720 1000183742 |
+----------------+---------------+------------+
| 2019-06-28 4251675720 1000183742 |
+----------------+---------------+------------+
| 2019-06-28 2113750655 100065856 |
+----------------+---------------+------------+
| 2019-06-28 3512075270 1002923999 |
+----------------+---------------+------------+
| 2019-06-28 4251998103 1003890261 |
+----------------+---------------+------------+
| 2019-06-28 4239113350 1004043945 |
+----------------+---------------+------------+
| 2019-06-28 8569030255 1004043945 |
+----------------+---------------+------------+
| 2019-06-28 6692802619 1004584989 |
+----------------+---------------+------------+
| 2019-06-28 6751615521 1005048991 |
+----------------+---------------+------------+
| 2019-06-28 1338818134 1005076529 |
+----------------+---------------+------------+
| 2019-06-28 1903780287 1005519781 |
+----------------+---------------+------------+
| 2019-06-28 3023132803 1005535434 |
+----------------+---------------+------------+
| 2019-06-28 3075990149 1006443568 |
+----------------+---------------+------------+
| 2019-06-28 1821112520 1007165898 |
+----------------+---------------+------------+
| 2019-06-28 4249904989 100753094 |
+----------------+---------------+------------+
| 2019-06-28 4230960972 1009300504 |
+----------------+---------------+------------+
| 2019-06-28 2254190165 1010611747 |
+----------------+---------------+------------+
';
my $regex = qr/\b\d{4}-\d{2}-\d{2}[ \t]+\b(\d{9,10}) {6}\t(\d{9,10})\b(?![\s\S]*\b\1 {6}\t\2)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}