$re = '/#\d+[(=](\w+)\((.*?)\)[;A-Z]/m';
$str = '#14(REPRESENTATION_RELATIONSHIP($,$,#293,#291)REPRESENTATION_RELATIONSHIP_WITH_TRANSFORMATION(#12)SHAPE_REPRESENTATION_RELATIONSHIP());
#35=MECHANICAL_DESIGN_GEOMETRIC_PRESENTATION_REPRESENTATION(\'\',#180,888.125521);
#25=ADVANCED_BREP_SHAPE_REPRESENTATION(\'\',(#29),#277);
#186=AXIS2_PLACEMENT_3D(\'\',#270,#230,#231);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);