using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(10\.[0-9]{4,}(?:\.[0-9]+)*\/(?:(?![\""&\'])\S)+)\b";
string input = @"Herbst, D. M., Griffith, N. R., & Slama, K. M. (2014). Rodeo cowboys: Conforming to masculine norms and help-seeking behaviors for depression. Journal of Rural Mental Health, 38, 20–35. http://dx.doi.org/10.1037/rmh0000008
Herbst, D. M., Griffith, N. R., & Slama, K. M. (2014). Rodeo cowboys: Conforming to masculine norms and help- seeking behaviors for depression. Journal of Rural Mental Health, 38, 20–35. doi:10.1037/rmh0000008
Example: https://doi.org/10.5468/ogs.2016.59.1.1
""Quantum tomography: Measured measurement"", Markus Aspelmeyer, nature physics January 2009, Volume 5, No 1, pp11-12; [doi:10.10.1038/nphys1170]
Held, Gilbert. Internetworking LANs and WANs (Second Edition), John Wiley & Sons, 1998, Published Online 05 Oct 2001. Chapter 1, Network Concepts (p 1-30) [doi:10.1002/0470841559.ch1]
Irino, T; Tada, R (2009): Chemical and mineral compositions of sediments from ODP Site 127-797. Geological Institute, University of Tokyo. [doi:10.1594/PANGAEA.726855]
Earthquake Event, Authored by Automated System:
Geofon operator (2009): GEOFON event gfz2009kciu (NW Balkan Region) GeoForschungsZentrum Potsdam(GFZ). [doi:10.1594/GFZ.GEOFON.gfz2009kciu]
Kraus, Stefan; del Valle, Rodolfo (2008): Geological map of Potter Peninsula (King George Island, South Shetland Islands, Antarctic Peninsula). Instituto Antártico Chileno, Punta Arenas, Chile & Instituto Antártico Argentino, Buenos Aires, Argentina. [doi:10.1594/PANGAEA.667386]
B. Kirchhof (2009) Silicone oil bubbles entrapped in the vitreous base during silicone oil removal, Video Journal of Vitreoretinal Surgery. [doi: 10.3207/2959859860]";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}