$re = '/((?=.*tes)(?=.*bb))|(?=.*aaaa)/';
$str = 'testaaa test aaaa
testaaa test bbbb
testaaa test cccc
aaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);