import Foundation
let pattern = #"\b(?!A1\d+)A1\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"A1+A1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{0}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)