re = /^## (\d+\.?){3}.+?(?=## \d)/
str = '## 8.6.0
- **Upload date:** November 19, 2020
- **Release date:** TBC
- **Internal version:** 1171
### Feature
- dsfdsfds
- sdfdsf
- dsfdsf
### Bug fixes
- sdfsaf
- sdfsad
- sdfsdfdsf
### Internal
- sadfsdfsda
- fsdfgsadfasd
- sdfsda
## 8.5.1
- **Upload date:** November 09, 2020
- **Release date:** November 12, 2020
- **Internal version:** 1170'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end