import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^```html\\s*(?<html>[\\s\\S]*?)```|(?:<!DOCTYPE html>\\s*)?<html[^>]*?>\\s*<head>[\\s\\S]*?<\\/head>\\s*<body[^>]*?>(?<body>[\\s\\S]*?)<\\/body>\\s*(?:<\\/html>)?)";
final String string = "```html\n"
+ "<!-- wp:mev/hero {\"media\":9609} -->\n"
+ "<div><img class=\"wp-block-mev-hero\" /></div>\n"
+ "<!-- /wp:mev/hero -->\n\n"
+ "<!-- wp:mev/container -->\n"
+ "<div><!-- wp:heading -->\n"
+ "<h2 class=\"wp-block-heading\" id=\"h-title\">Markedsføringsbyrå Oslo – gjør suksess mulig med Enklere Valg</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Hos Enklere Valg, et dedikert markedsføringsbyrå basert i Oslo, tilbyr vi essensielle markedsføringstjenester som er lett tilgjengelige for din bedrift. Som et fullservicebyrå navigerer vi deg gjennom dagens komplekse og krevende marked. Enten målet ditt er å forbedre synligheten gjennom betalt eller organisk markedsføring, tilbyr vi strategier tilpasset dine spesifikke behov. Med oss som din partner, kan du stole på vår kompetanse og erfaring til å skape reell verdi for din virksomhet.</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:spacer {\"height\":\"40px\"} -->\n"
+ "<div style=\"height:40px\" aria-hidden=\"true\" class=\"wp-block-spacer\"></div>\n"
+ "<!-- /wp:spacer -->\n\n"
+ "<!-- wp:contact-form-7/contact-form-selector {\"id\":10007,\"title\":\"Send forespørsel_copy\"} -->\n"
+ "<div class=\"wp-block-contact-form-7-contact-form-selector\">[contact-form-7 id=\"10007\" title=\"Send forespørsel_copy\"]</div>\n"
+ "<!-- /wp:contact-form-7/contact-form-selector -->\n\n"
+ "<!-- wp:spacer {\"height\":\"40px\"} -->\n"
+ "<div style=\"height:40px\" aria-hidden=\"true\" class=\"wp-block-spacer\"></div>\n"
+ "<!-- /wp:spacer -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<h3>Skreddersydde markedsføringsstrategier for økt synlighet</h3>\n"
+ "<p>Vi forstår at ingen bedrift er lik, og derfor tilpasser vi våre tjenester til hver enkelt kunde. Enten du ønsker raske resultater via betalt markedsføring, som Google Ads, eller annonsering på sosiale medier, eller du er interessert i bærekraftige resultater gjennom organisk markedsføring som SEO og innholdsproduksjon, har vi verktøyene og ekspertisen du trenger. Våre strategier sikrer at innholdet ditt resonnerer med målgruppen og styrker din tilstedeværelse i det digitale landskapet.</p>\n\n"
+ "<h3>Rådgivning og analyser for bedre beslutninger</h3>\n"
+ "<p>Gjennom grundige analyser av markedet, konkurrenter og målgruppe, utvikler vi realistiske og transparente planer som er skreddersydd for din bedrift. Våre rådgivere er klare til å bistå deg med beslutningsprosessen fra start til slutt. Vårt markedsføringsbyrå i Oslo er stolte av å levere tjenester gjennom Oslo Marketing Nettverk, noe som gir oss verdifull innsikt i lokale markedsbehov.</p>\n"
+ "<p>Med hovedkontor i Oslo, har vi kunnskap og kapasitet til å betjene bedrifter over hele landet. Vi tilbyr kurs og opplæring som kan styrke din bedrift ytterligere, enten i samarbeid med Google, hvor vi er Premier Partner, eller gjennom våre egne tilpassede kurs.</p>\n"
+ "<p>Enklere Valg er din dedikerte partner for markedsføring. Vi legger vekt på kundetilfredshet og vet at et vellykket samarbeid bygges på tillit og åpen kommunikasjon. Våre løsninger er ikke bare designet for kortsiktig gevinst, men for varig suksess og vekst.</p>\n"
+ "<p>Vi inviterer deg til å ta <a href=\"https://www.enklerevalg.no/kontakt/\">kontakt</a> for en uforpliktende samtale med vårt markedsføringsbyrå i Oslo. La oss hjelpe deg med å nå dine mål med skreddersydde løsninger som fungerer. Sammen kan vi finne ut om vi er den rette partneren for deg og din virksomhet. Vi gleder oss til å høre fra deg!</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:spacer {\"height\":\"40px\"} -->\n"
+ "<div style=\"height:40px\" aria-hidden=\"true\" class=\"wp-block-spacer\"></div>\n"
+ "<!-- /wp:spacer -->\n\n"
+ "<!-- wp:columns -->\n"
+ "<div class=\"wp-block-columns\"><!-- wp:column {\"style\":{\"elements\":{\"link\":{\"color\":{\"text\":\"var:preset|color|white\"}}},\"spacing\":{\"padding\":{\"top\":\"25px\",\"right\":\"25px\",\"bottom\":\"25px\",\"left\":\"25px\"}}},\"backgroundColor\":\"accent3\",\"textColor\":\"white\"} -->\n"
+ "<div class=\"wp-block-column has-white-color has-accent-3-background-color has-text-color has-background has-link-color\" style=\"padding-top:25px;padding-right:25px;padding-bottom:25px;padding-left:25px\"><!-- wp:heading -->\n"
+ "<h2 class=\"wp-block-heading\" id=\"h-digital-annonsering\">Digital annonsering</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Digital annonsering</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Google Ads</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Programmatisk annonsering</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Display-annonsering</p>\n"
+ "<!-- /wp:paragraph --></div>\n"
+ "<!-- /wp:column -->\n\n"
+ "<!-- wp:column {\"style\":{\"elements\":{\"link\":{\"color\":{\"text\":\"var:preset|color|white\"}}},\"spacing\":{\"padding\":{\"top\":\"25px\",\"right\":\"25px\",\"bottom\":\"25px\",\"left\":\"25px\"}}},\"backgroundColor\":\"accent3\",\"textColor\":\"white\"} -->\n"
+ "<div class=\"wp-block-column has-white-color has-accent-3-background-color has-text-color has-background has-link-color\" style=\"padding-top:25px;padding-right:25px;padding-bottom:25px;padding-left:25px\"><!-- wp:heading -->\n"
+ "<h2 class=\"wp-block-heading\" id=\"h-innholdsmarkedsforing\">Innholdsmarkedsføring</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Innholdsmarkedsføring</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>SEO</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>E-postmarkedsføring</p>\n"
+ "<!-- /wp:paragraph --></div>\n"
+ "<!-- /wp:column -->\n\n"
+ "<!-- wp:column {\"style\":{\"elements\":{\"link\":{\"color\":{\"text\":\"var:preset|color|white\"}}},\"spacing\":{\"padding\":{\"top\":\"25px\",\"right\":\"25px\",\"bottom\":\"25px\",\"left\":\"25px\"}}},\"backgroundColor\":\"accent3\",\"textColor\":\"white\"} -->\n"
+ "<div class=\"wp-block-column has-white-color has-accent-3-background-color has-text-color has-background has-link-color\" style=\"padding-top:25px;padding-right:25px;padding-bottom:25px;padding-left:25px\"><!-- wp:heading -->\n"
+ "<h2 class=\"wp-block-heading\" id=\"h-sosiale-medier\">Sosiale medier</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:spacer {\"height\":\"8px\"} -->\n"
+ "<div style=\"height:8px\" aria-hidden=\"true\" class=\"wp-block-spacer\"></div>\n"
+ "<!-- /wp:spacer -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Sosiale medier</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Facebook-annonsering</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Instagram-annonsering</p>\n"
+ "<!-- /wp:paragraph -->\n\n"
+ "<!-- wp:paragraph -->\n"
+ "<p>Youtube-markedsføring</p>\n"
+ "<!-- /wp:paragraph --></div>\n"
+ "<!-- /wp:column --></div>\n"
+ "<!-- /wp:columns -->\n\n"
+ "<!-- wp:spacer {\"height\":\"60px\"} -->\n"
+ "<div style=\"height:60px\" aria-hidden=\"true\" class=\"wp-block-spacer\"></div>\n"
+ "<!-- /wp:spacer -->\n\n"
+ "<!-- wp:heading -->\n"
+ "<h2 class=\"wp-block-heading\" id=\"h-caser\">Caser</h2>\n"
+ "<!-- /wp:heading -->\n\n"
+ "<!-- wp:mev/latest-cpt {\"postType\":\"cases\",\"layout\":\"grid\"} -->\n"
+ "<div class=\"wp-block-mev-latest-cpt\"></div>\n"
+ "<!-- /wp:mev/latest-cpt --></div>\n"
+ "<!-- /wp:mev/container -->\n"
+ "```";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}