use strict;
my $str = '+48 123 456 789
123456789
123 456 789
123-456-789
(+48) 123 456 789
+48123456789
0048123456789
Things not to capture:
12 345 67 89
1234567899876543211
654564654654654654
spam
1231312asdasdf1231231
123321
+4863227124';
my $regex = qr/\b(\(?(\+|00)?48\)?)?[ -]?\d{3}[ -]?\d{3}[ -]?\d{3}\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}