re = /(?<=t\(')*'.+?(?=',\n*.+?{)|(?<=t\(")*".+?(?=",\n*.+?{)/m
str = 'case \'cryptocurrencies\':
return this.$t(\'Text 1\', { company: this.$global.company, num: this.$global.companyAge });
case \'currencies\':
return this.$t(
\'Text 2\',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t("Text 3", { company: this.$global.company }) } ${ this.$t("Text 4", { num: this.bonus }) }
${ this.$t(\'Text 3\', { company: this.$global.company }) } ${ this.$t(\'Text 4\', { num: this.bonus }) }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end