import Foundation
let pattern = #"SoapWriter\.\d+ (?:- )?\[[0-9a-z]* [0-9a-z]*\] - (?:[0-9a-f]{8}-[0-9a-f]{4}-[1-5][0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12})? - ((?:.|\n|\r)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2021-02-25 14:06:25,810 [http-bio-8080-exec-70] INFO com.example.SoapWriter.27 - [7fbe6d227aa053b9 7fbe6d227aa053b9] - - <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><processSync xmlns="urn:soap"><in0><?xml version="1.0" encoding="UTF-8"?><ESROrder xmlns="http://www.example.com/xsd/sea" xmlns:icp="http://www.atis.org/obf/wir/wicis5/schemas">
<OrderDetails>
<RequestDetails>
<CustomerName>example</CustomerName>
<SupplierName>example</SupplierName>
<OrderType>example</OrderType>
<OrderSubtype>example</OrderSubtype>
<Event>new</Event>
</in0></processSync></soapenv:Body></soapenv:Envelope>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)