package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\*\*)(?<bold>[^**]+)(\*\*)|(?<normal>[^`*[~]+)|\*(?<italic>[^*]+)\*`)
var str = `**fi*rst b** some normal text here **second b** *first i* normal *second i* normal aggain`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}