$re = '/(^[ \t]*)Global/m';
$str = '
// Global GameFGimg:TImage=LoadImage("Img/Game/FG.png")
Global WAGamesLogo:TImage=LoadImage(ProcessURL("_Incbin\\Images\\Logo W@ Games 2.png"),ImageFlags)
// Объект, через который будем работать с джойстиками иксбокса
Global XB:XBox360 = New XBox360';
$subst = "$1public static";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;