package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(<first>|<last>|<state>)`)
var str = `<first>Micky</first>
<last>Mouse</last>
<state>CA</state>
<first>Donald</first>
<LAST>Duck</LAST>
<state>FL</state>
<FIRST>Gyro</FIRST>
<last>Gearloose</last>
<state>MA</state>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}