$re = '/^[a-z][a-z\d]*$(?<!\d)/m';
$str = 'ahmed0saber
0ahmedsaber
ahmedsaber0
ahmed_saber
a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);