using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![.\d])[-+]?(?:\d+(?:\.\d*)?|\.\d+)(?![.\d])";
string input = @"""Test string 1.234 0.155.1 5.67799350,-2.654657";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}