import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*(\\d{13}))?.*";
final String string = "Ceres Juice Apricot 12 x 1lt unit: 6001240102022\n"
+ "Ceres Juice Cranberry& Kiwi Juice 12 x 1lt... unit:\n"
+ "Ceres Juice Guava 12 x 1lt.. unit:6001240222829\n"
+ "Ceres Juice Orange 12x1lt... unit:\n"
+ "Ceres Juice Medley of Fruits 1L x 12 unit: 6001240100660111";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}