$re = '/(\.\/)?([A-Za-z0-9][A-Za-z0-9\/]+?)(\/)?$/m';
$str = './var/lib/test/
./var/lib/test
var/lib/test/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);