import re
regex = re.compile(r"<.*?>|&.*?;|\\n|\\xa0|(https|http)://.*?\"", flags=re.MULTILINE)
test_str = "<p>It’s time\\xa0for the season finale of Ontario Diagnostic Days!</p>\\n<p>The annual Ontario field crop diagnostic days held at Ridgetown, Elora, and Winchester are again virtual in 2021. On this live broadcast, University of Guelph professors Dave Hooker and Francois Tardif join host Shaun Haney to talk three hot topics that are sure to grab growers’ attention, as we look forward to the 2022 crop year.</p>\\n<p>Haney and Hooker kick off the show with a look at the state of fertilizer supply and demand and the significant cost growers could face in 2022 when feeding their crops. Hooker then digs into research work on\\xa0phosphorus and potassium and soil test levels, to determine how investing in these nutrients makes sense for 2022 corn and soybeans.</p>\\n<p>Nitrogen is also up for discussion. Hooker looks at the importance of rate and timing, split applications, and how growers could reduce environmental losses with help from\\xa0nitrogen inhibitors and stabilizers.</p>\\n<p>Tardif then joins Haney to look at the continuing spread of herbicide-resistant weeds across Ontario, discussing how waterhemp has spread dramatically, as well as the relentless march of glyphosate-resistant\\xa0Canada fleabane. He also discusses the potential for the dreaded Palmer amaranth to migrate north to Ontario.</p>\\n<p>How have these weeds spread so quickly? Tardif notes that while waterfowl and wind patterns are typically pegged as the culprits fuelling the spread, equipment operators also need to acknowledge their role in creating the problem. He says much has been made about the fact that Canada fleabane seeds can be found in the earth boundary layer and can move vast distances. This theory has been overblown, he asserts. Weed scientists are now more inclined to believe that local selection is much more important than long distance spread.</p>\\n<p>Hooker then rejoins the show to talk tar spot — the corn leaf disease that’s been showing up in many fields across southern Ontario this year. After a season <a href=\"https://www.realagriculture.com/2021/10/corn-school-inside-the-tar-spot-management-toolbox/\">recap from OMAFRA plant pathologist Albert Tenuta</a>, Hooker peers into the tar spot management toolbox to assess the level of tolerance current hybrids offer growers. He also discusses how hybrid choice will play a key role in defending corn crops against the disease in 2022 and beyond. <em>(More about the series after the video.)</em></p>\\n<!-- video --><div class=\"youtube-responsive\" id=\"realagvideo280475\" uk-scrollspy=\"hidden:false;\"><iframe width=\"640\" height=\"360\" data-src=\"https://www.realagriculture.com/media/rav-61782199a3ee5.html\" frameborder=\"0\" scrolling=\"no\" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen id=\"realagvideoframe280475\" class=\"realagvideoframe\" srcdoc=\"<a href="https://www.realagriculture.com/media/rav-61782199a3ee5.html\"> src="https://www.realagriculture.com/media/realag_iframe_placeholder.png\" alt="If player does not load, click here to refresh." width="100%" align="center"></a>\"></iframe></div>\\n<p>The organizing committees of these three highly successful in-field education and learning events are again partnering with crop researchers and extension, along with support from RealAgriculture and a host of sponsors to bring you a series of eight\\xa0<a href=\"https://www.realagriculture.com/ontariodiagnosticdays/\">Ontario Diagnostic Days</a>\\xa0episodes.</p>\\n<p>We would like to thank the following sponsoring organizations: The Grain Farmers of Ontario, AGRIS Co-operative, BASF, Bayer/DeKalb, Corteva/Pioneer, Great Lakes Grain, Maizex Seeds, The Mosaic Company, PRIDE Seeds, RealAgriculture, and Syngenta.</p>\\n<p>The series kicked off with this one-hour episode on Tuesday, July 20. A new episode is published every two weeks, on Tuesdays at 9 am Eastern, through to November 2, 2021. Each episode will highlight a general field crop agronomic theme and will be available\\xa0here on RealAgriculture\\xa0for viewing, as well as the\\xa0OMAFRA Field Crop News\\xa0website. All episodes will also be available in our main podcast feed.</p>\\n<p>The virtual video series gives the OMAFRA field crop team, research colleagues from the University of Guelph, and industry agronomists an opportunity to deliver diagnostic insights in a new way, sharing what attendees have come to expect from Diagnostic Days at Ridgetown, Elora, and Winchester. As part of the offering, continuing education credits (CEU) will also be available.</p>\\n<p>Historically, these in-person diagnostic days have provided some of the best opportunities for certified crop advisors (CCAs) to acquire a broad range of CEUs.</p>\\n<p>Certified crop advisors will be able to collect eight CEUs\\xa0by\\xa0<a href=\"https://bdc.ridgetownc.com/registration/?OfferingCode=1166#maincontent\">registering for the event here</a>. Registration is required for processing CEU credit requests and can be done up to December 1, 2021. Directions for applying for CEUs will be provided during each episode.</p>\\n<p>The videos are free and registration is not required for Grain Farmers of Ontario members, media, and those not seeking CEU credits.</p>\\n<p>Registration Fees\\xa0 — Only required if applying for CEU Credits</p>\\n<p>·\\xa0\\xa0\\xa0\\xa0\\xa0 $100 (plus HST) for eight CEU credits. A receipt/confirmation email will be provided.</p>\\n<p><a href=\"https://www.realagriculture.com/ontariodiagnosticdays/\">Click\\xa0here previous Ontario Diagnostic Days episodes.</p>\\n<p class=\"powerpress_links powerpress_subscribe_links\">Subscribe: <a href=\"https://itunes.apple.com/ca/podcast/realagricultures-podcasts/id975730628?mt=2&ls=1#episodeGuid=https%3A%2F%2Fwww.realagriculture.com%2F%3Fp%3D280387\" class=\"powerpress_link_subscribe powerpress_link_subscribe_itunes\" title=\"Subscribe on Apple Podcasts\" rel=\"nofollow\">Apple Podcasts</a> | <a href=\"https://subscribeonandroid.com/www.realagriculture.com/feed/podcast/\" class=\"powerpress_link_subscribe powerpress_link_subscribe_android\" title=\"Subscribe on Android\" rel=\"nofollow\">Android</a> | <a href=\"https://www.realagriculture.com/feed/podcast/\" class=\"powerpress_link_subscribe powerpress_link_subscribe_rss\" title=\"Subscribe via RSS\" rel=\"nofollow\">RSS</a></p><!--powerpress_player-->"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)