import re
regex = re.compile(r"(?:youtu\.?be(?:-nocookie)?(?:\.com)?(?:\/|watch\?v=|embed\/)+)([\w-]+)")
test_str = ("www.youtube.com/watch?v=dQw4w9WgXcQ\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
"https://youtu.be/dQw4w9WgXcQ\n"
"https://www.youtube.com/embed/dQw4w9WgXcQ\n"
"https://www.youtube-nocookie.com/embed/dQw4w9WgXcQ\n"
"https://youtu.be/dQw4w9WgXcQ?t=0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")