$re = '/\s+(?=-name\b)/m';
$str = '-title abc -name josh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);