re = /([^|\r])\R/m
str = '8778|44523|0||TENNESSEE|ADMINISTRATION||ROLL 169 BATCH 8|1947-09-22|0|OnBase
See Also 15990TT|'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result